Какой стиль именования фунций/переменных практиней

Кощей

if(!$needle) die("ooh");
Какой стиль именования фунций/переменных практиней

С суфиксками или префиками. Как лучше писать вначале причастность к определенному блоку действий, либо вначале указывать действие, а потом его уточнение.
Вот у меня есть варианты для контролера плеера:

#1 вариант
icon_play_update
icon_lyrics_update
clock_update
song_play
playlist_fill
playlist_save

#2 вариант
update_icon_play
update_icon_lyrics
update_clock
play_song
fill_playlist
save_playlist

Сразу скажу что не расматриваю сейчас объектный подход.
 

Nicholas

Новичок
вообще, именовать лучше по правилам английского языка.
Если мне память не изменяет, сначала идет существительное, затем глагол.

2clevel
а варианты соединения слов это тема отдельного холивара =)
 

itprog

Cruftsman
Nicholas
в повелительном наклонении сначала глагол потом существительное...
 

Dovg

Продвинутый новичок
Функция - это действие. Первым идет глагол
PlaySong();
Переменная -это существительное )
$IsSongPlaing = true;

ИМХО
 

Кощей

if(!$needle) die("ooh");
А если у вас много функций относящихся какой-то группы действий. К примеру функции управления плейлистом можно все начинать так
pl_save
pl_play
pl_load
pl_share
pl_set_default
pl_delete

Наглядней так с ними работать ведь.
 

Кощей

if(!$needle) die("ooh");
Angerslave
Я специально говорил, ооп не трогать :)

Практичней как в пхп, для разработчика, легче понять к чему относиться функция но названия длинные выходят.
 

Духовность™

Продвинутый новичок
zerkms
я имел в виду написание, когда первое слово, до знака `_` говорит о том, с чем эта функция работает:

array_
imap_
mysql_
xml_
 

zerkms

TDD infected
Команда форума
triumvirat
сразу бы и уточнил тогда, а то в пхп есть также и stripslashes и strip_tags
 

Духовность™

Продвинутый новичок
zerkms
вот ты умный, с кажи, а использовать классы как исключительно пространство имен для (статически-объявленных) функций - это хорошо или нет?

тогда бы было

array::sort();

или

mysuperfunctions::sort();

как идея?
 

zerkms

TDD infected
Команда форума
triumvirat
вот ты умный, с кажи, а использовать классы как исключительно пространство имен для (статически-объявленных) функций - это хорошо или нет?
1. не переходи на личности
2. в программировании мало ситуаций, когда однозначно можно сказать: "это хорошо, а это плохо"
 

maxwell

artifex
Автор оригинала: triumvirat
zerkms
я имел в виду написание, когда первое слово, до знака `_` говорит о том, с чем эта функция работает:

array_
imap_
mysql_
xml_
Фуу.. бред.
Для этого есть тип переменной. Если речь о пхп, то пхп есть и будет быдло-языком. Поэтому там абсолютно не важно как называть переменные.

Функции следует называть так:
mySuperPuperCoolFunction()

Переменные аналогично.

-~{}~ 29.06.08 16:43:

Dovg, функция это функция, а не действие.
 

zerkms

TDD infected
Команда форума
Функции следует
не нужно говорить так категорично :) нотации бывают разные. использование той или иной - дело вкуса и конвенции в проекте.
 

Духовность™

Продвинутый новичок
Фуу.. бред.
Для этого есть тип переменной. Если речь о пхп, то пхп есть и будет быдло-языком.
какой переменной? причем тут тип переменной? быдло-язык - тогда чего ты на этом форуме делаешь?
 
Сверху