Laravel laravel 8, tailwindcss, npm run dev

scandal

Новичок
Здравствуйте!
Начал изучать Laravel 8. На Windows 10 пытаюсь выполнить вот эти команды:
tailwindcss installation
1. npm install [email protected] --save-dev
2. npm install tailwindcss
3. composer require laravel-frontend-presets/tailwindcss --dev
4. php artisan ui tailwindcss
5. npm install
6. npm run dev

Последняя команда npm run dev выдает ошибку.
Посоветуйте, пожалуйста, как можно исправить?

Вот ошибка:
Код:
> @ dev D:\Laravel\project1
> npm run development


> development
> mix

TypeError: mix.js is not a function
    at Object.<anonymous> (D:\Laravel\project1\webpack.mix.js:15:4)
    at Module._compile (D:\Laravel\project1\node_modules\v8-compile-cache\v8-compile-cache.js:192:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.Module._load (internal/modules/cjs/loader.js:790:14)
    at Module.require (internal/modules/cjs/loader.js:974:19)
    at require (D:\Laravel\project1\node_modules\v8-compile-cache\v8-compile-cache.js:159:20)
    at module.exports (C:\Users\Hakimov\AppData\Roaming\npm\node_modules\laravel-mix\setup\webpack.config.js:8:5)
    at handleFunction (D:\Laravel\project1\node_modules\webpack-cli\bin\utils\prepareOptions.js:21:13)
    at prepareOptions (D:\Laravel\project1\node_modules\webpack-cli\bin\utils\prepareOptions.js:9:5)
    at requireConfig (D:\Laravel\project1\node_modules\webpack-cli\bin\utils\convert-argv.js:117:14)
    at D:\Laravel\project1\node_modules\webpack-cli\bin\utils\convert-argv.js:123:17
    at Array.forEach (<anonymous>)
    at module.exports (D:\Laravel\project1\node_modules\webpack-cli\bin\utils\convert-argv.js:121:15)
    at D:\Laravel\project1\node_modules\webpack-cli\bin\cli.js:71:45
    at Object.parse (D:\Laravel\project1\node_modules\webpack-cli\node_modules\yargs\yargs.js:576:18)
    at D:\Laravel\project1\node_modules\webpack-cli\bin\cli.js:49:8
    at Object.<anonymous> (D:\Laravel\project1\node_modules\webpack-cli\bin\cli.js:366:3)
    at Module._compile (internal/modules/cjs/loader.js:1085:14)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.Module._load (internal/modules/cjs/loader.js:790:14)
    at Module.require (internal/modules/cjs/loader.js:974:19)
    at require (internal/modules/cjs/helpers.js:92:18)
    at Object.<anonymous> (D:\Laravel\project1\node_modules\webpack\bin\webpack.js:156:2)
    at Module._compile (internal/modules/cjs/loader.js:1085:14)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.Module._load (internal/modules/cjs/loader.js:790:14)
    at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:76:12)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! @ dev: `npm run development`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @ dev script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Hakimov\AppData\Roaming\npm-cache\_logs\2021-07-10T16_37_12_065Z-debug.log

D:\Laravel\project1>
 

grigori

( ͡° ͜ʖ ͡°)
Команда форума
чувак, npm - это node.js, то есть, javascript, и к php это отношения не имеет
 
Сверху